Forum overview > Black screen on Windows build??
  • Black screen on Windows build??

    by korpse · Saturday, 10. September 2016, 13:04 h ~ 5 years ago

    I have another problem at my hands. I finally got the shaders working, but now the game shows a black screen, with every new build. The strange thing is, that Mac versions work with no problem, but Windows versions don't. I've tried to locate the problem but with no luck. Even the log files won't help. I suspect, that the root of the problem is, that I updated the Visionaire editor to 4.2.5. few days back, but our game is developed with 4.2. I tried to run the game with the newer version, but it didn't start and the editor gave me an error message saying that the data is corrupt. I switched back to 4.2. and everything seemed to be in order, until I got those shaders working and made a new build for the rest of my team members to test the game. They're running Windows, and the same problem occurs for both of them: black screen, but Task Manager tells it's a runtime error. But with my Mac everything runs nice and smooth.

    I'm running out of ideas, maybe someone smarter could check, what's wrong.
    Here's a link for the most recent prototype of the game (Windows build):
    And here's a zip file containing the project files:
  • by afrlme · Saturday, 10. September 2016, 14:38 h ~ 5 years ago
    I assume you exported the windows build via your mac? It's highly recommended that you export mac/ios stuff on a mac & windows stuff on a windows machine as sometimes the exports mess up.

    Other thing to take note of... never ever cross-pollute your project files by editing the same ved file on both a mac & windows machine as it can cause issues down the line with the project working fine on one os & somethings not working correctly on another. Why? No idea, but it's happened to me at least two or three times as I tend to work on windows machines but co-dev uses macs. I ended up scrapping first project & starting fresh on windows only to resolve my issues. We do a duplicate copy if we want to test on mac.

    Unfortunately my windows laptops hdd decided to pretty much give up life yesterday, so need to replace that ASAP. I do have vm installed on mac with windows 8.1 though so can try exporting a build on that & see if it works ok.
  • by afrlme · Saturday, 10. September 2016, 21:21 h ~ 5 years ago
    I can't get it to run on the mac via the mac editor. It just says game failed to init, but I shouldn't be getting that message as that's usually what it says when you haven't included the core basics (character, command interface, font, starting scene & active character, etc). But they all seem to be there.

    By the way... really like the artwork or temp artwork you've done for "Hortschloss_Stables_CUT1", reminds me of Ben Templesmiths art style. Mostly down to the sort watercolor / neon glow style colors you are using more than anything but still.

  • by SimonS · Saturday, 10. September 2016, 23:28 h ~ 5 years ago
    there is lonely point in the waysystem on scene "Sandbox" that causes a crash. You need to remove it or delete the waysystem. It's in the cut out part where two points are close.
  • by afrlme · Sunday, 11. September 2016, 00:18 h ~ 5 years ago
    That's it? It's not even the initial scene.

    Did you debug a dmp file or something to spot that as it's not something I would have considered looking for myself as it's not exactly the most obvious of issues?
  • by korpse · Sunday, 11. September 2016, 15:23 h ~ 5 years ago
    Thanks a lot guys! Now the game works with 4.2.5.
  • by afrlme · Sunday, 11. September 2016, 15:41 h ~ 5 years ago
    Oh, quick word of advice: it's recommended that you use regular characters for naming things in the editor. No special characters. I noticed that you like using Lua script for certain things & sometimes the special characters can cause issues with correctly accessing / updating data structure fields / tables.

    I forgot to mention it in my last reply.
  • New post